Regresar   Forum Original-Design: Foro de tutoriales Dreamweaver y PSP > Tutoriales Orignal-Design > Tutoriales PHP y MySQL > Ayuda & dudas
FAQ / Ayuda Lista de usuarios Calendario Buscar Posts de hoy Marcar como leído

Votanos!

Votanos Votanos

Responder
 
Herramientas Buscar en esta discusión Estilo
  #11  
Old 12-12-2007, 12:13 PM
sirviejo
 
Posts: n/a
Predeterminado

el archivo que eh publicado es para que lo alojes en el archivo que hace el envio del archivo al servidor, obviamente tenes que modificarlo para que traiga las variables del formulario que tenes en el otro .php
El error que sale por que hubo errores en la carga, principalmente por que no hay archivo. :P cualquier cosa en un rato me conecto desde el trabajo
Citar y responder
  #12  
Old 12-12-2007, 01:26 PM
Joan
 
Posts: n/a
Predeterminado

He agregado tu script dentro del campo del formulario , y cuando hago la prueba, me sale el siguiente error:

Parse error: parse error, unexpected '/' in C:\wamp\www\comnou-php\subir_archivo.php on line 374

pero en la linea 374, tengo lo siguiente:

<input name="archivo" type="file" id="archivo" value="" size="32" />

( el archivo"subir_archivo", es el que copié del tutorial y dice lo siguiente:
<?php
$directorio_archivo = /httpdocs/imagenes-sql/ ; // tipo /home/user/public_html/archivos/
$nombre = strtr($_FILES['archivo']['name'], "ñ'ÁÉÍÓÚÀÈÌÒÙáé*óúäëïöü*èì òù ", "n-AEIOUAEIOUaeiouaeiouaeiou_");
$tamanio = $_FILES['archivo']['size'];
$tipo = $_FILES['archivo']['type'];
copy($_FILES['archivo']['tmp_name'], $directorio_archivo.$nombre);
echo "el archivo se a subido correctamente al servidor<br>";
?>


porcierto !!! me dijiste que tenia que modificar alguna cossilla del formulario, pero no se ver que tengo que modificar..!!!
disculpa mi ignorancia !!!
Citar y responder
  #13  
Old 12-12-2007, 04:27 PM
sirviejo
 
Posts: n/a
Predeterminado aver..

el script que te di es para que lo cambiaras por el que estas usando es una alternativa... no para poner en el script del formulario. Ahora en un rato te pongo todo el script completo! no te preocupes. Saludos.
Citar y responder
  #14  
Old 12-12-2007, 04:42 PM
sirviejo
 
Posts: n/a
Predeterminado

bueno tengo un poco de tiempo asi que pongo el formulario que deberias usar con mi script...

<form action="subir_archivo.php" method="post" name="f_prof" id="f_prof" enctype="multipart/form-data">
Archivo:
<input type='file' name="archivo" id="archivo">
<input type='submit' name="ok" value="ENVIAR" id="ok">
</form>
Citar y responder
  #15  
Old 12-12-2007, 04:51 PM
Joan
 
Posts: n/a
Predeterminado

Gracias , mil gracias ...
Por si te sirve de ayuda, te posteo como tengo los archibos :
1º archibo:
prova-fotos.php

script del formulario para enviar las fotos:
<form action="subir_archivo.php" method="POST" enctype="multipart/form-data" name="form1">
<p>
<input name="archivo" type="file" id="archivo" value="" size="32" />
</p>
<input type="submit" name="Submit" value="Enviar" />
</form>

2º archivo:
subir_archivo.php

Script del archivo:
<?php
$directorio_archivo = "/httpdocs/imagenes-sql "; // tipo /home/user/public_html/archivos/
$nombre = strtr($_FILES['archivo']['name'], "ñ'ÁÉÍÓÚÀÈÌÒÙáé*óúäëïöü*èì òù ", "n-AEIOUAEIOUaeiouaeiouaeiou_");
$tamanio = $_FILES['archivo']['size'];
$tipo = $_FILES['archivo']['type'];
copy($_FILES['archivo']['tmp_name'], $directorio_archivo.$nombre);
echo "el archivo se a subido correctamente al servidor<br>";
?>

Por si te sirve de ayuda, la carpeta imagenes-sql ( de httpdocs ) esta con permiso de escritura 777 ).

Si hago la prueba con el servidor web, me sale (el archivo se a subido correctamente al servidor ), pero su voy a mi administrador de archivos del plesk de mi web, entro en la carpeta "imagenes-sql" y no hay nada.

Gracias de antemano...
Citar y responder
  #16  
Old 12-12-2007, 06:31 PM
sirviejo
 
Posts: n/a
Predeterminado

mm me gustaria si puedieras poner toda la estructura de las carpetas q tenes en tu servidor. Por ejemplo donde pones el index.php?
Citar y responder
  #17  
Old 12-13-2007, 06:51 AM
Joan
 
Posts: n/a
Predeterminado

aqui tienes lo que me pediste, la estructura de mis archibos es la siguiente :


es decir, la carpeta donde va a parar todos los archibos y carpetas que voy creando van a parar a " httpdocs" es decir, " index.php" esta justo dentro de "httpdocs" ( httpdocs/index.php )

Espero que sea lo que necesitas...
Haber si tenemos suerte y me me puedes ayudar... de hecho ya lo estas haciendo ... te lo agradezco...haver si podemos solucionarlo...

Editado por Joan en 12-14-2007 a las 06:25 AM.
Citar y responder
  #18  
Old 12-13-2007, 10:51 AM
sirviejo
 
Posts: n/a
Predeterminado

uno de los errores que puedo ver es que estas incluyendo el directorio httpdocs, en el directorio destino, proba poniendo solamente /imagenes-sql
Citar y responder
  #19  
Old 12-13-2007, 01:35 PM
Joan
 
Posts: n/a
Predeterminado

Lo he intentado tal y como me has dicho, sin el "httpdocs/", pero me sigue saliendo la confirmacion del envio del archibo, pero cuando voy a la carpeta "imagenes-sql" no me sale nada, esta vacia la carpeta... ya no se que hacer.. estoy desesperado...
Help..my !!!

Ahora esta de la siguiente manera: ( sigue fallando, no me sube la foto al servidor de la web )

<?php
$directorio_archivo = "/imagenes-sql "; // tipo /home/user/public_html/archivos/
$nombre = strtr($_FILES['archivo']['name'], "ñ'ÁÉÍÓÚÀÈÌÒÙáé*óúäëïöü*èì òù ", "n-AEIOUAEIOUaeiouaeiouaeiou_");
$tamanio = $_FILES['archivo']['size'];
$tipo = $_FILES['archivo']['type'];
copy($_FILES['archivo']['tmp_name'], $directorio_archivo.$nombre);
echo "el archivo se a subido correctamente al servidor<br>";
?>
Citar y responder
  #20  
Old 12-13-2007, 04:20 PM
Joan
 
Posts: n/a
Predeterminado

Ya esta solucionada amigo mio... el problema era que le faltaba el punto antes de / imagenes-sql
debia ponet:
./imagenes-sql

mil gracias, mil gracias, al final, provando cosillas he podido encontrar el error...
Te agradezco que me hayas seguido ayudadndo y apoyando en el scrips... ers genial... es el mejor foro que he visto, porque la mayoria te dicen dan accesos a otras paginas con tutoriales y esas cosas, aqui tu te pones en nuestra piel y intentas ver el error y poder solucionarlo... mil gracias.

Editado por Joan en 12-14-2007 a las 06:24 AM.
Citar y responder
Responder


Herramientas Buscar en esta discusión
Buscar en esta discusión:

Búsqueda avanzada
Estilo

Reglas del foro
No puedes iniciar una discusión
No puedes responder a una discusión
No puedes agregar archivos adjuntos
No puedes editar tus posts

El código vB está activado
Emotíconos está activado
El código [IMG] está activado
El código HTML está desactivado
Ir a

Todas las horas son GMT. La hora es 06:04 AM.


Copyright 2007-2008